Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2011
    Location
    san francisco, ca
    Posts
    61

    Default 2005 with ETM problem?

    The wife's car is a 2005 xc with 206k miles and for the past few of weeks it has been having an intermittent stumble. It is usually on the freeway at a constant speed between 2000 and 2200 rpm . It only happened twice on surface streets, once going around a corner and once leaving a stop sign. Both of those times it was a similar rpm range. I've cleaned the throttle body and changed the plugs with no effect. I've gotten two codes P1221 and P0193. The first was about two weeks ago while my wife was driving and the last was yesterday while I was driving. The p0193 code came on after I put my foot in it to stop it from stumbling. I cleared them both and they haven't returned. Does this sound like an ETM problem? I was kind of thinking it wasn't fuel related because it was only under very certain conditions. Could it be MAF related?

  2. #2
    Join Date
    Feb 2010
    Location
    Virginia Beach
    Posts
    4,064

    Default

    You’ve got a fuel pressure code in addition to your TPS code.

    Get this thing diagnosed. Check fuel pressure with a good gauge. Read codes with VIDA. Do an ETM sweep with VIDA.

    Firing up the parts cannon based on codes and guesses is a horribly expensive, and ineffective, way to troubleshoot.
    Current Fleet:
    2016 Tundra Crewmax 4WD 1794
    2005 MB S600 (114K, Michelin AS3+, LiquiMoly 0W40)
    2005 MB SL600 (50K, Michelin AS4, Mobil 1 0W40)
    2004 V70R (six speed M66, Mobil 1 5W30)
    2002 V70-XC (275K, HPL Euro 0W30)
    2002 V70-T5 (216K, IPD bars, Bilsteins)
    2001 V70-T5 (120K, IPD downpipe, cat back and other mods)
    1932 Packard Sedan (straight 8, dual sidemounts, original paint and interior, Shell Rotella 15W40)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •