Results 1 to 2 of 2
  1. #1
    Join Date
    Nov 2014
    Location
    USA
    Posts
    65

    Default Windshield Rain Strip Clip Headaches

    Sorry if this is a stupid question, but I'm trying to fix the problem of some broken windshield rain strip clips on my 2003 XC70, and I don't know what I'm doing wrong.

    The original blue clips are part number 9484524. The replacements I ordered are yellow that are supposed to fit have an extra plastic flange on the side. I figured this was for wider compatibility, but they don't seem to fit. They will not slide onto the locating pins on the car body, nor do they seem to clip into the rain strip even as a test.

    Any suggestions for finding the right part? I'm tired of having this strip flap around at highway speeds.

  2. #2
    Join Date
    Feb 2016
    Location
    Windsor, ON, Canada
    Posts
    36

    Default

    there's two types of clips on that channel. The one nearest the top is actually white and a different part number. The three lower ones are the yellow one, correct, but when I installed mine I tore off that little flange you're talking about and then slid it to size. Yours don't fit into the pins? Check this out (scroll down the upper stuff doesn't apply here):

    https://www.skandix.de/en/documents/...-rail/3000453/
    Hers- 04 XC70 2.5T, 300KM
    His- 04 S60 2.4, 310KM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •