Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2021
    Posts
    1

    Default 2015.5 XC60 engine knocks/pings after cold start

    Been noticing a knock or pinging sound from our 2015.5 XC60 T5 after a cold start. I can somewhat hear it when idling, and the heavier the load when accelerating, the louder it is. It only last a few minutes. I have about a 1 mile drive to the highway on 45mph road with 4 stop signs. About halfway to the highway I start to noticed the noise abating, and by the time I hit the on ramp it is gone. Is this normal, or something to be concerned about?

  2. #2
    Join Date
    Apr 2003
    Location
    New England
    Posts
    404

    Default

    Could it be expansion of metal. Pinging is typically heard under acceleration regardless of engine being warmed up.
    14xc60 3.0T
    03xc70 (Killed 12/16)
    1998 v70 (retired)

  3. #3
    Join Date
    Mar 2008
    Location
    Longmont, CO, US
    Posts
    250

    Default

    could also be lack of lubrication on start up
    need to hit the hwy every so often to get all the fluids moved through the engine
    Hailing from the Majestic Rocky Mountain High
    RIP 04-08-09

    Extras: Bilstein Hd's, Zimmerman Cross-Drilled Rotors, K&N Air Filter
    IPD HD TCV, Stylin Motors Silicone Hoses, Silverstars, 8000k HID Fogs
    179k
    It is illegal to get this high in other states.

    Need OEM Volvo Parts?
    Call Daryl Waltrip Volvo
    (800) 689-0021
    Ask for Jamie or Don

  4. #4
    Join Date
    Apr 2003
    Location
    New England
    Posts
    404

    Default

    Quote Originally Posted by PaperToast View Post
    could also be lack of lubrication on start up
    need to hit the hwy every so often to get all the fluids moved through the engine
    Especially if it uses a timing chain that has stretched
    14xc60 3.0T
    03xc70 (Killed 12/16)
    1998 v70 (retired)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •