Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2012
    Posts
    135

    Default Smell of coolant!

    So, it's time to add a little heat to the cabin in my 2006 xc70. Problem is...turned on the heat and ...smell of antifreeze. No coolant loss in reservoir. Pulled the mats, nothing damp under heater core area. I owned an 850 for many years, did several heater cores on that car, so I know where to look...Dry.
    Any thoughts? I have a reservoir cap that i once put a valve in so that I can pressurize the system. Used it on the 850 and found a head gasket leak. I don't want to do it to this car...fear of blowing something out!
    A.

  2. #2
    Join Date
    Aug 2017
    Location
    Pleasanton CA USA
    Posts
    453

    Default

    Is it possible the coolant has a tiny steam leak in the engine compartment, and it's entering the cabin thru the intake vents? If you keep the "recirc" ON (outdoor air closed), does it go away?

    If you don't smell it until the coolant has time to build up pressure, it's likely a steam leak. In a very quiet environment (nighttime), you can sometimes hear the soft hiss sound after shutting off a warmed-up engine. A tiny steam leak in a dry environment only leaves a small greenish-white residue...the steam evaporates.
    2013 XC70 T6 Flamenco Red (hers)
    2015 XC70 T6 Seashell Metallic (his)
    past: 13 Volvos going back to '74 242 sedan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •