Results 1 to 2 of 2
  1. #1
    Join Date
    Jan 2009
    Location
    Sacramento, CA
    Posts
    120

    Default Aerated Power Steering Fluid and Pump Noise

    My power steering recently became noisy and I assumed my car needed a new PS pump after 207K miles. Thanks to some good information from June on the MVS site it turns out the reservoir can cause the fluid to aerate and pump noise. I did see air bubbles in the fluid while the car was running. After pulling out the reservoir I could hear something rattling inside so I cut open the reservoir to find out what was going on. There was a support piece that broke away from the return line tube inside the reservoir and also a crack in the tube almost the full length of the tube. I think it's the crack that was causing the aerated fluid because the crack extended about the fluid level.
    Anyway, a new power steering reservoir solved the pump noise problem, which was a less expensive fix and avoided the hassle of replacing the pump and still having a noisy pump. It looks like sometime during the 2005 model year the PS reservoir design was changed so this problem may primarily affect models prior to 2005.
    Attached Thumbnails Attached Thumbnails PS reservoir crack along length of retrun line.jpg   PS reservoir cut in half.jpg   PS reservoir crack along length of retrun line III.jpg  

  2. #2
    Join Date
    Aug 2020
    Location
    Seattle-ish
    Posts
    10

    Default

    That's very interesting - this issue is well known but no one I have read has cut open the reservoir AFAIK to pinpoint that part of the problem. Kudos.

    Swedespeed classifieds usually has some take-off 2005+ reservoirs.

    Annoyingly, dealerships still install the defective reservoirs despite this issue being known for over a decade! The po of my car (2004) took it into a dealership 18 months ago for PS issues. They replaced the reservoir with the exact same design instead of the revision, and charged several hundreds for the privilege. Idiotic. Oh, and it did nothing for the PS issues, I fixed those after I bought it. The "new" reservoir was already leaking a year later.

    Thank you for taking the time to share this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •