Results 1 to 10 of 10
  1. #1
    Join Date
    Jun 2020
    Location
    SLC
    Posts
    6

    Question Befuddled: replacing signal stalk leaves it not working; high beams stuck on

    I'm looking for your experienced advice to send me down the right troubleshooting avenues. This for a 2001 V70 XC.

    The original turn signal stalk broke off about half an inch above the steering wheel shaft. Even with that stub of a stalk, the turn signals worked great (although the computer controls weren't accessible). I've tried replacing the entire stalk unit with both a new OEM part and a used OEM part. In both instances, the turn signal stops working and the high beams stay on constantly. I've checked all relevant fuses - I think - but I'm at an impasse as to where to look next.

    Has anyone dealt with this? Any ideas?

    Thanks.

  2. #2
    Join Date
    Feb 2010
    Location
    Virginia Beach
    Posts
    3,891

    Default

    Im befuddled, too...

    Wrong part? Stalk not seated fully?

    Didn’t have this problem back when I did mine.

    You may find this handy for future work: https://www.volvoxc.com/resources/how-to/

    In particular: https://www.volvoxc.com/0/resources/...lk-on-2002.pdf
    Current Fleet:
    2016 Tundra Crewmax 4WD 1794
    2005 MB S600 (100K, Michelin AS3+, M1 0W40)
    2002 V70-XC (258K, Castrol Edge 0W40)
    2002 V70-T5 (208K, IPD bars, Bilsteins)
    2001 V70-T5 (92K)
    1932 Packard Sedan (straight 8, dual sidemounts, original paint and interior, Shell Rotella 15W40)

  3. #3
    Join Date
    Dec 2009
    Location
    GA
    Posts
    1,346

    Default

    Quote Originally Posted by mojowkn View Post
    Any ideas?
    Makes no sense - what happens when you put the old broken one back on?

  4. #4
    Join Date
    Jun 2020
    Location
    SLC
    Posts
    6

    Default

    Quote Originally Posted by hoonk View Post
    Makes no sense - what happens when you put the old broken one back on?
    Good question. It functions as before - broken stalk, but one can signal, etc., and it works as it should.

  5. #5
    Join Date
    Jun 2020
    Location
    SLC
    Posts
    6

    Default

    Quote Originally Posted by Astro14 View Post
    Im befuddled, too...

    Wrong part? Stalk not seated fully?

    Didnít have this problem back when I did mine.

    You may find this handy for future work: https://www.volvoxc.com/resources/how-to/

    In particular: https://www.volvoxc.com/0/resources/...lk-on-2002.pdf
    Thanks. I can't find any cause for it, and I've ordered and tried two different parts just to be sure. I have even disassembled the used one and it's identical to the one I'm replacing. I can't figure it out.
    And I did wonder about the stalk not being seated fully, but I've tried it with these two different replacement parts and have carefully seated them both. A few times .

  6. #6
    Join Date
    Feb 2010
    Location
    Virginia Beach
    Posts
    3,891

    Default

    When you say OEM - did you get it from a Volvo dealer?

    Or a place like eBay...

    Because in the latter case, I would blame the part. Lots of fakes out there...LOTS of fakes, and they look the same, but they sure don't work the same.

    IPD, FCP Euro, Volvo dealer are worthy of your trust and business.
    Current Fleet:
    2016 Tundra Crewmax 4WD 1794
    2005 MB S600 (100K, Michelin AS3+, M1 0W40)
    2002 V70-XC (258K, Castrol Edge 0W40)
    2002 V70-T5 (208K, IPD bars, Bilsteins)
    2001 V70-T5 (92K)
    1932 Packard Sedan (straight 8, dual sidemounts, original paint and interior, Shell Rotella 15W40)

  7. #7
    Join Date
    Aug 2017
    Location
    Pleasanton CA USA
    Posts
    415

    Default

    Looking at FCP Euro's search on your model year, there are 3 variations on the turn signal stalk:

    https://www.fcpeuro.com/Volvo-parts/...=5&b=6&d=59&v=

    31268578 - w/ Trip Computer up to chassis # 348999 (last 6 digits of VIN) -- gray color

    21368577 - without Trip Computer up to chassis # 314999 - charcoal color NO THUMBWHEEL RING

    31268575 - charcoal color

    Can you see a p/n printed or molded into the original stalk? Does the chassis # info help? Does your severed tip have the Trip Computer thumbwheel?

    I was surprised that FCP Euro's search doesn't designate RHD vs. LHD variants....hmmm?
    Last edited by pbierre; Yesterday at 02:20 PM.
    2013 XC70 T6 Flamenco Red (hers)
    2015 XC70 T6 Seashell Metallic (his)
    past: 13 Volvos going back to '74 242 sedan

  8. #8
    Join Date
    Jun 2020
    Location
    SLC
    Posts
    6

    Default

    Astro - thanks for the idea. I did get the original one from a volvo dealer (new one) and then got a used one from a pick n' pull place on ebay. So caveat emptor, right! I'll definitely use your recommendations when I try again .

  9. #9
    Join Date
    Jun 2020
    Location
    SLC
    Posts
    6

    Default

    Quote Originally Posted by pbierre View Post
    Looking at FCP Euro's search on your model year, there are 3 variations on the turn signal stalk:

    https://www.fcpeuro.com/Volvo-parts/...=5&b=6&d=59&v=

    31268578 - w/ Trip Computer up to chassis # 348999 (last 6 digits of VIN) -- gray color

    21368577 - without Trip Computer up to chassis # 314999 - charcoal color NO THUMBWHEEL RING

    31268575 - charcoal color

    Can you see a p/n printed or molded into the original stalk? Does the chassis # info help? Does your severed tip have the Trip Computer thumbwheel?

    I was surprised that FCP Euro's search doesn't designate RHD vs. LHD variants....hmmm?
    Thanks! I didn't realize there were three variants. I'm going to check this as soon as I get home tonight and report back.

  10. #10
    Join Date
    Jun 2020
    Location
    SLC
    Posts
    6

    Default

    Quote Originally Posted by mojowkn View Post
    Thanks! I didn't realize there were three variants. I'm going to check this as soon as I get home tonight and report back.
    So, it turns out that the first one you listed is the one I need based on VIN - and neither of the replacements I had ordered were the same part number (so much for trusting non-FCPEuro sources for year/model matching). I'll report back after it arrives. Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •