Results 1 to 3 of 3
  1. #1
    Join Date
    Aug 2019
    Location
    Worcester, MA.
    Posts
    4

    Default 2007 XCV70 No am Radio:

    Just acquired this car. with 167k miles.
    Only issues are, fog lights not working, and am side of radio has No reception. FM mode is fine.
    When I press the am button, station preset buttons or scan mode nothing happens.
    I'm wondering if there's an antenna issue or Is there a programming process for the am side of radio?
    Thanks for your attention.
    Dana

  2. #2
    Join Date
    Aug 2017
    Location
    Pleasanton CA USA
    Posts
    368

    Default

    Quote Originally Posted by Dana Lewis View Post
    Just acquired this car. with 167k miles.
    Only issues are, fog lights not working, and am side of radio has No reception. FM mode is fine.
    When I press the am button, station preset buttons or scan mode nothing happens.
    I'm wondering if there's an antenna issue or Is there a programming process for the am side of radio?
    Thanks for your attention.
    Dana
    AM radiowaves are very long -- the length of a football field, so there isn't any external antenna for an AM receiver. That points to a failed component in the radio. A good replacement unit can be found by Googling the "HU xxx" model number of your radio.

  3. #3
    Join Date
    Feb 2010
    Location
    Virginia Beach
    Posts
    3,792

    Default

    Sounds like the head unit is bad. A used unit would be the way to go. Make sure itís the same year (for both color and compatibility).

    A place like Erie Vovo, which has a huge selection of used parts and a lifetime guarantee is the way to go.

    Itís an easy job, but disconnect the battery first. When you take out the Climate Control module below it (for screw access) you interrupt the CAN BUS. If electricity is flowing between modules, this interruption will cause an airbag (SRS) warning that can only be reset by VIDA...

    Ask me how I know...
    Current Fleet:
    2016 Tundra Crewmax 4WD 1794
    2005 MB S600 (100K, Michelin AS3+, M1 0W40)
    2002 V70-XC (238K, Castrol Edge 0W40)
    2002 V70-T5 (195K, IPD bars, Bilsteins)
    2001 V70-T5 (76K)
    1932 Packard Sedan (straight 8, dual sidemounts, original paint and interior, Shell Rotella 15W40)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •