Results 1 to 5 of 5
  1. #1
    Join Date
    May 2006
    Location
    Houston TX
    Posts
    185

    Default soft pops in front end

    2015 xc70 T6 25,000 mile

    Wife recently notices soft pops from front end of car while turning into driveways for parking - or going over speed bumps slowly.

    Dealer replaced lower stabilizer bushing and drivers side strut and mount - not related dealer replaced right front wheel bearing -

    I am clueless - could the strut towers nave cracks?? I have heard the sound and it is subtle but its there only on sharp turns at slow speed - both sides

  2. #2
    Join Date
    Aug 2017
    Location
    Pleasanton CA USA
    Posts
    413

    Default

    Is the sound coming from one side...does the soft pop only happen when one wheel is going over a bump? Find some speed humps and test each wheel going over separately.

    When I have a problem with wheels-suspension that's a stumper, I'll take it to Big O. They test drive it and provide their opinion. You decide if they are 100% confident in their opinion. If the repair involves taking apart the strut stack, you're not going to be able to do that yourself.

  3. #3
    Join Date
    May 2006
    Location
    Houston TX
    Posts
    185

    Default

    Big O??

    So far stab bar bushings - left front strut and subframe mounts - still a soft pop when torsional loads happen - a sharp slow turn on a steep drive way - still there - if the radio was on you would not hear it - cant hear if you are going fast only real slow

  4. #4
    Join Date
    Jan 2015
    Location
    Calgary, AB
    Posts
    13

    Default

    Are you still experiencing this problem? You might look into the sway bar end links. This was my problem a couple of years ago, but that was around 70K miles not 25K. You could test by undoing the the end links and going for a short ride over small bumps that would have caused the issue normally. Obviously if the sound is no longer there, you've found the issue.
    '06 XC70 (Ice White) - 2.5T-Auto -93K Miles to-date
    '93 850 GLT -2.4L-Std - the Red Rocket - gone
    '80 240DL -B21F-Std - killed in 2015 by a Mazda outside our house @282k kms

  5. #5
    Join Date
    May 2006
    Location
    Houston TX
    Posts
    185

    Default

    RESOLVED

    Volvo rep happened to be at dealer - we were about to remove the front end - and take out axles - rep took a ride and proclaimed " brake pads"

    HUh?

    Seems the new xc90's have a same issue - its the clearance of the brake pad to the caliper - removed pas and coated the edge with a silicone ceramic goo - no noise

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •