Results 1 to 3 of 3
  1. #1
    Join Date
    May 2019
    Location
    Indianapolis
    Posts
    12

    Default P0017 with Timing Belt Change

    Hello,

    New to the XC community. I just bought an XC70 and thought I would do some preventative maintenance, as the car came with no maintenance records...
    I went for the timing/serpentine belts, their tensioners/idler, and water pump first over this weekend. The timing belt had been replaced beforehand as it was a ContiTech belt. I got the water pump to seal on my second try (which was frustrating), but the car threw a crank/cam correlation error the day after I had done the work. The car has run fine since I did the belt, and the first half-hour trip did not present any codes.
    I am going to try resetting the belt tonight, and to see if the timing is actually off. I have read that I should advance the crank/cams passed the timing marks by 90 degrees (also read 180 degrees somewhere), and then bring them counterclockwise back to the timing marks to set the CVVT. Is this correct? I did not do this on my first attempt, maybe this is why the crank/cams are out of sync.

    If anyone has any further info I would appreciate the help. I hope the belt didn't somehow jump overnight, and that I was simply a tooth off when I first installed. The car still runs just fine right now, so I don't think I have caused any damage.

    Thank you.

  2. #2
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    631

    Default

    I had the exact same thing happen. I never read that you need to advance the crank past the timing marks. I had both P0016, which eventually went away but I still get P0017 on a regular basis. It is totally random and eventually goes away.....watching this thread to see if there is a solution.
    2020 Subaru Outback XT - Pearl White Loaded-huge improvement over 2013!
    1955 Ford F-250 - 223 IL6, 4 Speed with Granny Gear, 109 HP, 4.88 Rear
    2017 Maserati Ghibli - Blu Emozione - GONE!
    2013 2013 Subaru Outback - charcoal Grey, Eyesight Collision Avoidance 110k miles
    2007 2007 XC70, Barents Blue, Charcoal Leather 215k miles
    1978 Bitchin' Chevrolet Z28 Camaro - Fuel Injected 383ci SB Dyno'd at 452HP 462FT/LBs Torque
    My build thread: http://www.nastyz28.com/forum/showthread.php?t=276139

  3. #3
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    631

    Default

    Not sure if you ever came up with an answer. Switching to 0-W40 mobil 1 seemed to help.....still would love to know the answer though...
    2020 Subaru Outback XT - Pearl White Loaded-huge improvement over 2013!
    1955 Ford F-250 - 223 IL6, 4 Speed with Granny Gear, 109 HP, 4.88 Rear
    2017 Maserati Ghibli - Blu Emozione - GONE!
    2013 2013 Subaru Outback - charcoal Grey, Eyesight Collision Avoidance 110k miles
    2007 2007 XC70, Barents Blue, Charcoal Leather 215k miles
    1978 Bitchin' Chevrolet Z28 Camaro - Fuel Injected 383ci SB Dyno'd at 452HP 462FT/LBs Torque
    My build thread: http://www.nastyz28.com/forum/showthread.php?t=276139

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •