Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    Join Date
    Mar 2013
    Location
    Anchorage, Alaska
    Posts
    418

    Default Slight Intermitent Deceleration Just After Take Off

    Hello folks, just noticed an issue right after initial taking off. The issue is more noticeable when I had stopped and had the engine off for awhile and then take off. The car kinda starts to have intermittent 'holding' (deceleration) as if it is losing gas. It continues for about twenty to one-hundred feet then drives normally. No issue at highway speed.

    Thanks
    2001 Volvo XC70/AWD/Auto/Turbo/146kMiles (Brown)
    2001 Volvo V70XC/AWD/Auto/Turbo/144kMiles (Maroon)
    2006 Toyota Sienna LE/AWD 93K (Green)
    --------------------------------------------------------------------------------------
    1985 BMW (E23) 735i(US)/AUTO/209K Miles (Parked since 2011)
    1997 Mazda MPV/AUTO/4WD/173K Miles (Parked since 2008)
    2002 Subaru Outback L.L. Bean/3.0/131K/AWD (Parked since 2017)

  2. #2
    Join Date
    Mar 2013
    Location
    Anchorage, Alaska
    Posts
    418

    Default

    Quote Originally Posted by Oka View Post
    Hello folks, just noticed an issue right after initial taking off. The issue is more noticeable when I had stopped and had the engine off for awhile and then take off. The car kinda starts to have intermittent 'holding' (deceleration) as if it is losing gas. It continues for about twenty to one-hundred feet then drives normally. No issue at highway speed.

    Thanks
    UPDATE

    I just noticed the light deceleration starts at about 20MPH for about 50/100feet. A little latter, the more I step on the gas the more it acts like it's going to stop. My work is about fifteen minutes from home and after about half the way home, the car started driving smoothly again.
    2001 Volvo XC70/AWD/Auto/Turbo/146kMiles (Brown)
    2001 Volvo V70XC/AWD/Auto/Turbo/144kMiles (Maroon)
    2006 Toyota Sienna LE/AWD 93K (Green)
    --------------------------------------------------------------------------------------
    1985 BMW (E23) 735i(US)/AUTO/209K Miles (Parked since 2011)
    1997 Mazda MPV/AUTO/4WD/173K Miles (Parked since 2008)
    2002 Subaru Outback L.L. Bean/3.0/131K/AWD (Parked since 2017)

  3. #3
    Join Date
    Mar 2005
    Location
    Pacific Northwest
    Posts
    1,921

    Default

    Ok, ruled out MAF, see if you can find someone with Volvo diag tool (VIDA DiCE) and run an ETM sweep test to see the condition of your TPS. TPS is a contact based resistive strip that measures the throttle butterfly angle. Over time, the strip gets scratched resulting in wrong angle readings. A dealer / independent can do this in < 1 hour time so figure that for cost.

    Another sensor to consider swapping is MAP sensor. It sets on the plastic tube between intercooler and ETM. And since you have a duplicate car, maybe also swap the fuel pressure sensor too?
    Past Volvos : 01 V70 T5, 01/02 V70XC, 02 V70 NA, 00 V70XC
    Current EV/Hybrid : 13 Tesla S85, 11 Gen3 Prius
    Friends cars under my care 17 Audi A4 Quattro DSG (B9) 05 Audi A4 Manual 6sp Quattro (B7) 04 e320 V6 Auto, 05 Accord 2.4, 08 Element 2.4, 08 Camry Hybrid
    Past Others : 01/03 VW MK4 Turbo/NA/01M. Gen1 Prius, Gen1 CRV, Gen2 Rav4, 02 Town&Country, 06 Corolla, 12 Audi A4 Quattro (B8), 07 Civic 1.6
    http://www.freewebs.com/howardsvolvos/

  4. #4
    Join Date
    Mar 2005
    Location
    Pacific Northwest
    Posts
    1,921

    Default

    Since you have 2001s with known ETM issues, what is the ETM status? (rebuild? replaced? if so, how many miles on current ETM?)
    Past Volvos : 01 V70 T5, 01/02 V70XC, 02 V70 NA, 00 V70XC
    Current EV/Hybrid : 13 Tesla S85, 11 Gen3 Prius
    Friends cars under my care 17 Audi A4 Quattro DSG (B9) 05 Audi A4 Manual 6sp Quattro (B7) 04 e320 V6 Auto, 05 Accord 2.4, 08 Element 2.4, 08 Camry Hybrid
    Past Others : 01/03 VW MK4 Turbo/NA/01M. Gen1 Prius, Gen1 CRV, Gen2 Rav4, 02 Town&Country, 06 Corolla, 12 Audi A4 Quattro (B8), 07 Civic 1.6
    http://www.freewebs.com/howardsvolvos/

  5. #5
    Join Date
    Mar 2013
    Location
    Anchorage, Alaska
    Posts
    418

    Default

    Quote Originally Posted by howardc64 View Post
    Since you have 2001s with known ETM issues, what is the ETM status? (rebuild? replaced? if so, how many miles on current ETM?)
    I don't know. This would be my second year with the car.
    2001 Volvo XC70/AWD/Auto/Turbo/146kMiles (Brown)
    2001 Volvo V70XC/AWD/Auto/Turbo/144kMiles (Maroon)
    2006 Toyota Sienna LE/AWD 93K (Green)
    --------------------------------------------------------------------------------------
    1985 BMW (E23) 735i(US)/AUTO/209K Miles (Parked since 2011)
    1997 Mazda MPV/AUTO/4WD/173K Miles (Parked since 2008)
    2002 Subaru Outback L.L. Bean/3.0/131K/AWD (Parked since 2017)

  6. #6
    Join Date
    Mar 2005
    Location
    Pacific Northwest
    Posts
    1,921

    Default

    01 ETMs fails at around 100k miles YMMV. Link in my signature has ETM info. White sticker = original, yellow sticker = replaced. That would be a good starting point.
    Past Volvos : 01 V70 T5, 01/02 V70XC, 02 V70 NA, 00 V70XC
    Current EV/Hybrid : 13 Tesla S85, 11 Gen3 Prius
    Friends cars under my care 17 Audi A4 Quattro DSG (B9) 05 Audi A4 Manual 6sp Quattro (B7) 04 e320 V6 Auto, 05 Accord 2.4, 08 Element 2.4, 08 Camry Hybrid
    Past Others : 01/03 VW MK4 Turbo/NA/01M. Gen1 Prius, Gen1 CRV, Gen2 Rav4, 02 Town&Country, 06 Corolla, 12 Audi A4 Quattro (B8), 07 Civic 1.6
    http://www.freewebs.com/howardsvolvos/

  7. #7
    Join Date
    Mar 2013
    Location
    Anchorage, Alaska
    Posts
    418

    Default

    Quote Originally Posted by howardc64 View Post
    White sticker = original, yellow sticker = replaced.
    Went to your link but I do not get the color code information you mentioned.
    Last edited by Oka; 05-01-2019 at 07:14 AM.
    2001 Volvo XC70/AWD/Auto/Turbo/146kMiles (Brown)
    2001 Volvo V70XC/AWD/Auto/Turbo/144kMiles (Maroon)
    2006 Toyota Sienna LE/AWD 93K (Green)
    --------------------------------------------------------------------------------------
    1985 BMW (E23) 735i(US)/AUTO/209K Miles (Parked since 2011)
    1997 Mazda MPV/AUTO/4WD/173K Miles (Parked since 2008)
    2002 Subaru Outback L.L. Bean/3.0/131K/AWD (Parked since 2017)

  8. #8
    Join Date
    Mar 2013
    Location
    Anchorage, Alaska
    Posts
    418

    Default

    For the ETM, which should I consider, cleanup (service it), refurbished or new one?
    New ETM (OEM) is kinda pricey.
    Last edited by Oka; 05-01-2019 at 01:42 AM.
    2001 Volvo XC70/AWD/Auto/Turbo/146kMiles (Brown)
    2001 Volvo V70XC/AWD/Auto/Turbo/144kMiles (Maroon)
    2006 Toyota Sienna LE/AWD 93K (Green)
    --------------------------------------------------------------------------------------
    1985 BMW (E23) 735i(US)/AUTO/209K Miles (Parked since 2011)
    1997 Mazda MPV/AUTO/4WD/173K Miles (Parked since 2008)
    2002 Subaru Outback L.L. Bean/3.0/131K/AWD (Parked since 2017)

  9. #9
    Join Date
    Mar 2005
    Location
    Pacific Northwest
    Posts
    1,921

    Default

    Quote Originally Posted by Oka View Post
    For the ETM, which should I consider, cleanup (service it), refurbished or new one?
    New ETM (OEM) is kinda pricey.
    Cleaning won't do much if common TPS failure. Cheapest solution is to buy Sacer SA-300 TPS kit (~$100 on ebay) and rebuilt it yourself. Its what Xemodex use for rebuild. If you can find a Volvo diag tool, it can run an "ETM sweeptest" to check TPS condition.

    Other suggestions such as fuel filter and fuel pressure rail sensor are interesting possibilities. Not sure how you'd test those beyond blind swapping. Maybe fuel pressure sensor provide readable analog signal output if can reach wires with probes?

    i've also had a MAF that would cut out engine throttle response randomly. No codes. Since you have 2 01 Volvos, you can swap parts and see. Its actually how I found my MAF problem (also had 2 01s haha)
    Past Volvos : 01 V70 T5, 01/02 V70XC, 02 V70 NA, 00 V70XC
    Current EV/Hybrid : 13 Tesla S85, 11 Gen3 Prius
    Friends cars under my care 17 Audi A4 Quattro DSG (B9) 05 Audi A4 Manual 6sp Quattro (B7) 04 e320 V6 Auto, 05 Accord 2.4, 08 Element 2.4, 08 Camry Hybrid
    Past Others : 01/03 VW MK4 Turbo/NA/01M. Gen1 Prius, Gen1 CRV, Gen2 Rav4, 02 Town&Country, 06 Corolla, 12 Audi A4 Quattro (B8), 07 Civic 1.6
    http://www.freewebs.com/howardsvolvos/

  10. #10
    Join Date
    Nov 2018
    Location
    CT
    Posts
    39

    Default

    I had a similar issue in an 05, albeit at a different speed range. Turned out to be the fuel rail pressure sensor.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •