Results 1 to 6 of 6
  1. #1
    Join Date
    Jan 2019
    Location
    CT
    Posts
    3

    Default 2007 XC70 HU-650 question

    I've been looking into Bluetooth solutions for my 2007 and am having real problems using a GROM(my 2006 had no issues with the GROM.) When I go to Crutchfield to examine replacing the HU-650 I get a lot of warnings about having to rewire the speakers due to the amplifier under the passenger seat. When attempting to install the GROM I noticed the back of the HU-650 has two circular plugs, one for a CD changer and the other one I think is for the amplifier(has less pins than the CD changer.) There is nothing plugged into the either of those plugs on the HU-650. I know I don't have the CD changer but seeing there is no other plug back there does that also mean I do not have an amplifier?

    Thanks

  2. #2
    Join Date
    Dec 2009
    Location
    GA
    Posts
    1,411

    Default

    Quote Originally Posted by lynnejohn View Post
    no other plug back there does that also mean I do not have an amplifier?
    The amp (if you have one) is mounted under the front of the passenger seat, and easily visible with the seat all the way back

  3. #3
    Join Date
    Jan 2019
    Location
    CT
    Posts
    3

    Default

    Quote Originally Posted by hoonk View Post
    The amp (if you have one) is mounted under the front of the passenger seat, and easily visible with the seat all the way back
    So it would be mounted to the seat itself(not under the carpet?) I see some plastic thingy with a spring(some wires attached) on the bottom brace of the seat, but nothing looking like a amp. There is only one speaker per door in the car so I'm pretty sure there is no amp in the vehicle. The reason I ask is that it appears if the car has no amp there are quite a few options for radio's that have Bluetooth support but enable the use of steering wheel controls. Cars with the better OEM radio/amp setup require a lot of extra wiring.

    Thanks,
    lynnejohn

  4. #4
    Join Date
    Dec 2009
    Location
    GA
    Posts
    1,411

    Default

    "easily visible with the seat all the way back"

    It is not hidden under the carpet, and is bolted to the floor of the car

  5. #5
    Join Date
    Jan 2019
    Location
    CT
    Posts
    3

    Default

    Quote Originally Posted by hoonk View Post
    "easily visible with the seat all the way back"

    It is not hidden under the carpet, and is bolted to the floor of the car
    I get what you are saying but I wanted to be sure that I was not misunderstanding "visible". There is nothing on the carpet, only that small plastic piece(and harness) attached to the bottom bracket of the seat. Thanks for the information and I'll do a short write up of how things go once I get a new unit installed.

  6. #6
    Join Date
    Apr 2003
    Location
    Devon PA
    Posts
    11,409

    Default

    They did not come with an external amp, but you can add the PA200 (watt) amp if you want to.
    None of this has anything to do with your GROM, perhaps it was not installed properly.
    If it was, something is wrong with the GROM not the radio.
    All emails please use: jrl1194 (at) aol.com

    2007 V70 2.5T White/Oak, 112K miles. My daily driver and GORGEOUS
    2000 V70R wife's. Won't sell, now at 148K miles !! and still (almost) perfect.
    2000 S70 GLT SE with 29,000 miles!!! A time capsule, V70R front bumper, Volans, etc. SOLD!!! (I Will regret selling this!)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •