Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2018
    Location
    Pasadena, California
    Posts
    3

    Unhappy Lift Springs Knocking

    I recently put on the 2'' lift from bad swede onto my 2004 xc70. I got it installed at American Tire Depot along with the Discovers AT 225/70R16s and the front springs knock up against the spring well. I did not install new struts or a new spring seat but I contacted bad swede to see if they had had the issue and they said new struts and spring seat might help but upon further inspection i noticed the strut mount from the engine bay looks off center. Im not too trusting of the work the installers did. Would new struts or spring seat fix this knocking? Or did the installers mess up somewhere? Pictures of the strut mount from the engine bay, the spring is knocking to the side where it looks the top of the strut leans.Click image for larger version. 

Name:	IMG_5291.jpg 
Views:	28 
Size:	95.3 KB 
ID:	8876Click image for larger version. 

Name:	IMG_5290.jpg 
Views:	25 
Size:	95.8 KB 
ID:	8877Click image for larger version. 

Name:	IMG_5289.jpg 
Views:	23 
Size:	91.1 KB 
ID:	8878Click image for larger version. 

Name:	IMG_5299.jpg 
Views:	26 
Size:	92.8 KB 
ID:	8875

  2. #2
    Join Date
    Dec 2009
    Location
    GA
    Posts
    1,281

    Default

    Quote Originally Posted by nicklusnia View Post
    i noticed the strut mount from the engine bay looks off center.

    Would new struts or spring seat fix this knocking?
    Put a wrench on the nut on top of the pictured strut - if you can turn the wrench the strut cushion/spring seat is broken and will be noisy. Is sure looks like it from the pictures and they should have been replaced when the springs were put on, sorry.

    The struts will have to be removed and springs recompressed to replace the cushions. Be sure to use the latest part number, they are thicker/more durable and used in the xc90.
    Last edited by hoonk; 12-15-2018 at 01:36 AM.

  3. #3
    Join Date
    Apr 2017
    Location
    San Diego
    Posts
    66

    Default

    Something is wrong with the strut assembly, and I think I agree with hoonk that it's the spring seat. The top of the shock should be centered in the strut bearing. It's the spring seat that centers the shock shaft on the strut bearing. So I think it's the spring seat that has an issue. I'd replace both sides.
    Brett

  4. #4
    Join Date
    Mar 2008
    Location
    Western Head, Nova Scotia
    Posts
    3,089

    Default

    Quote Originally Posted by Brett San Diego View Post
    Something is wrong with the strut assembly, and I think I agree with hoonk that it's the spring seat. The top of the shock should be centered in the strut bearing. It's the spring seat that centers the shock shaft on the strut bearing. So I think it's the spring seat that has an issue. I'd replace both sides.
    Brett
    You definitely have a blown upper spring seat. The shock rod has punched out the metal bush in the middle of the seat. Just replaced one just like this on my '05 this last summer.

    Cheers,

    Bill
    Western Head, NS CDN

    '08 BMW 750i (Black Sapphire)-204K kms to-date
    '05 XC70 (Lava Sand)-296K kms to-date
    '02 V70XC-gone @393K kms
    '05 V70R (Magic Blue)-120K mi to-date - gone
    '96 854R (Red)-real CDN-spec 5-speed R - gone @270k kms
    And other Volvos and misc. Euro stuff

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •