Results 1 to 6 of 6

Thread: IPD Sway Bar

  1. #1
    Join Date
    Oct 2001
    Posts
    4

    Default Imported post

    My dealer (also located in IPD's home town)says my sway bar is not working right. The poly bushings don't
    match up well with the stock mounts for the sway bar unit.

    Has anyone installed an IPD sway bar and have you encountered any problems with the bars/bushings
    squeking?

    mine is really noisy. The bar works great (sway-wise) but fit under the car seems to be another issue???

  2. #2
    Join Date
    Aug 2001
    Location
    West Vancouver, Canada
    Posts
    2,161

    Default Imported post

    Welcome to v70xc.com!

    I haven't really any direct information for you regarding this issue but was wondering... is your sway bar specifically built for the XC or for 70/800 series in general?  Reason I ask is I don't recall seeing any XC products in IPD's catalogues.

    In order to accomodate the additional ride height, the bushing, especially fore and aft, placement will probably be slightly different on the XC than on the standard wagons.




    PS, you've got a great town... you may have seen it mentioned in a different thread, but I spent some time in Portland a couple weeks ago... and I'm sold

  3. #3
    Join Date
    Jan 2002
    Location
    Portland Oregon
    Posts
    1

    Default Imported post

    Hello,

    I just joined this site tonight and saw your post about a noisy bar. Has the problem been resolved yet? Please let us know if we can help. What you describe, doesn't sound normal. I drove a '98 XC for a couple of years with our bars on it and never had a problem. The AWD kit is a popular seller and we'd sure like to know if there is a problem. e-mail me at scott@ipdusa.com or give the office a call at 800-444-6473 and we'll arrange to take a look at it.

    Thanks!

  4. #4
    Join Date
    May 2002
    Posts
    2

    Lightbulb Imported post

    I've had IPD sway bars on my '98 XC for about a year. The problem that I have is that there is less than 1/4th inch between front bar and accordian section of the down pipe. When I start out from a stop the engine moves slightly on the rubber motor mounts and vibrates against the sway bar. I thought that I might resolve this by replacing the rubber upper mount with the poly one that IPD also sells, but it had no effect. Regardless of how slowly I start from a stop I must listen to this rattling vibration for a few seconds each time. Otherwise I love them, it takes turns at speed as though it were on rails. I've added just about every upgrade that IPD offers for the XC and this is the only one that's not been entirely satisfactory.

  5. #5
    Join Date
    Jun 2002
    Posts
    2

    Default Imported post

    My front IPD works great. The front bars squaked and my mechanic lubed the bushings (alot).
    That took care of it.  IPD sent me new blue bushings.

  6. #6
    Join Date
    Aug 2002
    Location
    Madison, WI
    Posts
    900

    Default Imported post

    I have had noisy bushings on other cars, rubber and urathane alike. I have had stellar luck with Stalube sythetic caliper grease. I think IPD sells it, I know some parts stores do, also bavauto.com sells it. just call them if you don't see it online. 800-535-2002.

    jason
    Jason,

    Riding with the Big Dog.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •