Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2015
    Location
    San Diego
    Posts
    2

    Default 2002 XC70 Electrical multiple issues

    Hi. This is my first post so let me know if I do anything wrong.

    My Volvo has been experiencing a few problems and it seems to be getting worse. It is a '02. It has approximately 185k mile on it. It's in working order for the most part. Here's what I've notice:

    • The message center works sometimes and the rest of the time it appears off or as jumbled up letters.

    • Every once in a while the radio changes stations on its own.

    • After a while I noticed the driver side window periodically not responding.

    • Then I noticed the driver side seat periodically not responding.

    • Most recently the passenger side low beam went out. I replaced it with a new bulb and it still doesn't work.



    I've read some things about soldering points on the CPU or replacing relays, but I would really appreciate some input before I start tearing into things.

  2. #2
    Join Date
    Mar 2005
    Location
    Pacific Northwest
    Posts
    1,921

    Default

    Quote Originally Posted by badelectrical View Post
    • The message center works sometimes and the rest of the time it appears off or as jumbled up letters.
    Common problem with failing contacts on the big motorola chip on the circuit board. Reflow helped an 02 I worked on. But very fine pitch so make sure you find someone with proper equipment (ie not Radioshack soldering iron)

    http://www.freewebs.com/howardsvolvo....htm#948779827

    Quote Originally Posted by badelectrical View Post
    • After a while I noticed the driver side window periodically not responding.
    Probably DDM (Driver Door Module) seems to fail with high enough frequency. Volvo diag tool (VIDA/DiCE) would provide more definitive codes and where to chase.

    Quote Originally Posted by badelectrical View Post
    • Every once in a while the radio changes stations on its own.

    • Then I noticed the driver side seat periodically not responding.

    • Most recently the passenger side low beam went out. I replaced it with a new bulb and it still doesn't work.
    VIDA/DiCE is probably best starting point to find any current or stored codes. The diag tool will record when (mileage, how many starts ago etc..) the fault happens even if intermittent. $150 for Chinese clone with copy of Volvo software. Best installed in a virtual machine to avoid software component collision with base PC OS.
    Past Volvos : 01 V70 T5, 01/02 V70XC, 02 V70 NA, 00 V70XC
    Current EV/Hybrid : 13 Tesla S85, 11 Gen3 Prius
    Friends cars under my care 17 Audi A4 Quattro DSG (B9) 05 Audi A4 Manual 6sp Quattro (B7) 04 e320 V6 Auto, 05 Accord 2.4, 08 Element 2.4, 08 Camry Hybrid
    Past Others : 01/03 VW MK4 Turbo/NA/01M. Gen1 Prius, Gen1 CRV, Gen2 Rav4, 02 Town&Country, 06 Corolla, 12 Audi A4 Quattro (B8), 07 Civic 1.6
    http://www.freewebs.com/howardsvolvos/

  3. #3
    Join Date
    Mar 2015
    Location
    San Diego
    Posts
    2

    Default

    Thanks for the reply man. What a great forum this is

    Quote Originally Posted by howardc64 View Post
    Volvo diag tool (VIDA/DiCE) would provide more definitive codes and where to chase.
    Do I have to go to a Volvo dealership for this tool?

    Looks like I have some more detective work to do. I'll update soon.

  4. #4
    Join Date
    Mar 2005
    Location
    Pacific Northwest
    Posts
    1,921

    Default

    Quote Originally Posted by badelectrical View Post
    Do I have to go to a Volvo dealership for this tool?
    Dealers have the tool but not for sale. They will read codes for you at > $100/hour. You can buy a clone made in China version for ~$100 (wow, they've dropped in price) and they give you a copy of the Volvo diag software. google shop "vida/dice" and there are a lot of sources. I read about batches of poor quality clone tools not too long ago so perhaps other members can comment which online website they have recently purchased a working tool.

    As for installation, it can be tricky. google "vida dice installation" and there are few good directions. In the past, the software uses older version of Internet Explorer and maybe a few other older version of windows component (Did my install a few years ago, don't know if this is still the case). So either your system's software versions match or find someone savoy with computers and setup a VM installation of Windows for you.

    Hope this helps.
    Past Volvos : 01 V70 T5, 01/02 V70XC, 02 V70 NA, 00 V70XC
    Current EV/Hybrid : 13 Tesla S85, 11 Gen3 Prius
    Friends cars under my care 17 Audi A4 Quattro DSG (B9) 05 Audi A4 Manual 6sp Quattro (B7) 04 e320 V6 Auto, 05 Accord 2.4, 08 Element 2.4, 08 Camry Hybrid
    Past Others : 01/03 VW MK4 Turbo/NA/01M. Gen1 Prius, Gen1 CRV, Gen2 Rav4, 02 Town&Country, 06 Corolla, 12 Audi A4 Quattro (B8), 07 Civic 1.6
    http://www.freewebs.com/howardsvolvos/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •