Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13
  1. #11
    Join Date
    Apr 2011
    Location
    Tampa, FL
    Posts
    107

    Default

    Quote Originally Posted by RockitShip View Post
    Thanks for the info/link Gary. That persons solution... and a decent one at that... is also something I am debating.
    Mornin' guys. "That person" is me. The fix I did on my windshield molding is holding up extremely well. I've had absolutely no issues with this fix I'm happy to say. Hope it works out as well for you.

    I can post up a current photo if needed but it looks exactly the same as it did when installed.
    Jim<><
    '04 XC70 AWD CrossCountry 2.5T
    '99 Land Rover Discovery I (sold )
    '86 Saab 900i (sold a long time ago...)

  2. #12
    Join Date
    Jun 2019
    Location
    WV
    Posts
    1

    Default

    Hey RockitShip,
    Did you ever find a work around for those trim pieces or at least the rubber part? I was looking to replace just the rubber trim and buy new clips to hold it but nobody seems to know the type of molding. Short of tearing a piece off and measuring it i'm at a loss. Hope that you figured it out as you can even get the whole trim piece now.

  3. #13
    Join Date
    Jan 2018
    Location
    Grand Rapids, MI
    Posts
    64

    Default

    Are you guys referring to the trim on the A pillar? The rubber on mine is shot. As with many Volvo's I've seen. That piece can be replaced but they are not cheap.
    IF IT AIN'T BROKE - DON'T FIX IT!
    04 Volvo XC70 5LT 120k "Floatey" Ruby Red, Valvoline 0W40
    07 Honda Accord V6 115k Silver, Napa 5W20 Blend
    07 Honda Accord L4 110k Bronze, Napa 5W20 Blend
    96 MB C220 L4 330k, 20W40

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •