Search:

Type: Posts; User: Terryfil

Search: Search took 0.00 seconds.

  1. Replies
    9
    Views
    2,548

    I got a text last night and the code has went...

    I got a text last night and the code has went away. Re-timing the exhaust cam resolved it. The phasers can be finiky, I'm just glad I'm finally done with chasing codes on this jalopy
  2. Replies
    9
    Views
    2,548

    I didn't remove the VVT hub on this thing either....

    I didn't remove the VVT hub on this thing either. Only thing I can think of that causing the cam reset valve code is maybe the exhaust cam turned a bit when I put the new belt on. I took it apart...
  3. Replies
    9
    Views
    2,548

    Turned out that it was the PCV system. Banjo...

    Turned out that it was the PCV system. Banjo bolt was plugged. We did the timing belt, water pump, tensioner/idler at the same time. No MAF codes now, but it's throwing "Exhaust cam reset valve"...
  4. Replies
    9
    Views
    2,548

    I'm going after the evap system next. Since it's...

    I'm going after the evap system next. Since it's due for a service anyway. Is there a way to check these valves without VIDA? I've got an OTC scanner.
    It's got the symptoms your explaining. It...
  5. Replies
    9
    Views
    2,548

    2006 XC70 MAF code, new sensor, no change

    I'm working on a friends '06 XC70, it's got rough idle, sometimes stalls after startup, stumbles on acceleration. Seems less when it's warmed up. It started on a trip out of town, threw MAF code and...
Results 1 to 5 of 5