Search:

Type: Posts; User: RockOcean

Search: Search took 0.00 seconds.

  1. Replies
    12
    Views
    1,917

    I finally got to taking the head off and sure...

    I finally got to taking the head off and sure enough one of the exhaust valves is burnt or is it chipped? I do not see any sign of a chipped off piece damaging anything. The cams and cam journals all...
  2. Replies
    12
    Views
    1,917

    I picked up a bore scope and was hoping to get...

    I picked up a bore scope and was hoping to get the one that you can rig up to look up at the valves. No such luck on that. Everything looks ok to me, im surprise the cross hatch is still so visible....
  3. Replies
    12
    Views
    1,917

    I swapped around the injectors and did not get...

    I swapped around the injectors and did not get the code to change. I checked for spark and it has spark. I did the compression check and got 100 on all cylinders but nothing even registered on the...
  4. Replies
    12
    Views
    1,917

    Thanks Brett I appreciate the feed back. I will...

    Thanks Brett I appreciate the feed back. I will try that method, I assume fuel pressure gauges are pretty standard and affordable I hope. LOL Youtube University is pretty awesome sometimes. I...
  5. Replies
    12
    Views
    1,917

    I see what you mean with the Iridium fine wire...

    I see what you mean with the Iridium fine wire electrode. But like I said, I ran a set of these same plugs NGK BKR6E and TPI coil packs for the past 40k miles with no problems at all. I appreciate...
  6. Replies
    12
    Views
    1,917

    They are the same plugs and coil packs that have...

    They are the same plugs and coil packs that have worked just fine for the past 40k miles. Will let you know exactly what brand and part numbers they are when I get home tomorrow.
  7. Replies
    12
    Views
    1,917

    Sticky Oil on #3 Spark Plug

    Hello all,

    I have a 2003 XC70 with 240K on it. I recently got a CEL for ECM-3503 & 3533 Misfire cylinder3 - start up . Changed all the plugs and replaced that coil pack still getting those codes.....
  8. Replies
    8
    Views
    1,798

    I do not have any DEM codes. I had CEM-1A64 and...

    I do not have any DEM codes. I had CEM-1A64 and BCM-0094 codes. But after replacing the rear wheel bearing I now only have the CEM-1A64 code. The wheel bearing was good but the magnet ring inside it...
  9. Replies
    8
    Views
    1,798

    Yes I have definitely gone way pasted that point...

    Yes I have definitely gone way pasted that point now :~ ) But thank you for that great info. I am just going to take the prop shaft out for the summer, and bolt my broken DEM on with just the one...
  10. Replies
    8
    Views
    1,798

    Yes I have talked to xemodex, gone thru their...

    Yes I have talked to xemodex, gone thru their flow chart twice. I have taken the pump out and tested it, changed the filter & haldex fluid, and changed the diff oil.

    I have heard of DEM swapping...
  11. Replies
    8
    Views
    1,798

    DEM bolt broke off

    I removed my DEM to get the part numbers off it so I could order a used one. The DEM is not communicating with Vida Dice so I am figuring it is bad (yes all fuses and wiring have been checked). ...
  12. Replies
    8
    Views
    7,212

    [QUOTE=AKAMick;201587]The fronts are usually the...

    [QUOTE=AKAMick;201587]The fronts are usually the problem with failed rings, rears are part of the hub, seldom fail.[/QUOTE

    Hmmmm I replaced the front driveshafts a year ago so I would think they...
  13. Replies
    8
    Views
    7,212

    Will have a better look at them later. Do you...

    Will have a better look at them later. Do you know how to see the rears? They are pretty covered up back there seems like you'd have to pull the hub.
  14. Replies
    8
    Views
    7,212

    Yeah still saving up for the ole VIDA. You know...

    Yeah still saving up for the ole VIDA. You know the person that sells them and a Windows 7 laptop by chance?
  15. Replies
    8
    Views
    7,212

    Brakes ticking, ABS light.

    When I start up my 2003 XC70 the ABS light is on. Once I start moving the ABS light goes off and I can hear a ticking noise that sounds like its going from one brake to the next. Once I hit around 10...
  16. Replies
    0
    Views
    382

    Help with pin pointing AWD problem.

    I have a 2003 Volvo XC70 (188,000mi) the PO said that the prop shaft needed to be rebuilt. I rebuilt the prop shaft and once installed the front diff made an awful noise and the prop shaft did not...
  17. Replies
    0
    Views
    761

    Rear diff Haldex leak from pinhole

    I got a very small leak coming from the pinhole in the photo below. Seems to be leaking from the diff side since the level for that is pretty low and the haldex fluid level is spot on. Anybody know...
  18. Freshly rebuilt prop shaft making a rotating rubbing noise.

    My girlfriend recently purchased a 2003 XC70 with 170k on it. It needed new brakes, a fan motor, and the prop shaft was removed because it was making a noise. Since buying it we also had to replace...
  19. Freshly rebuilt prop shaft making a rotating rubbing noise.

    My girlfriend recently purchased a 2003 XC70 with 170k on it. It needed new brakes, a fan motor, and the prop shaft was removed because it was making a noise. Since buying it we also had to replace...
Results 1 to 19 of 21