View Full Version : Disabling keyboard shortcuts in message editor

01-01-2005, 03:31 PM
Let me start by saying I'm really impressed by the technical quality of these forums.

One thing that's been slightly annoying for me is that key combinations used for text editing in Safari appear to activate functions in the volvoXC.com message editor. For example control-p, which in many programs including Safari is used to move to the previous line, activates posting preview in the message editor. Another one I always hit is control-b (move 'back' one character), which activates insertion of bold text in the message editor.

Does anyone know if there's a way to disable these keyboard shortcuts in the volvoXC.com message editor? These key combinations are used by a lot of browsers that support emacs-style editing commands (like Linux browsers and virtually all Mac programs based on Cocoa, which is inherited from the old Unix-based NeXT platform).

This is not a huge deal but those key combos are now hardwired into my spine and I always end up activationg a bunch of unwanted previews when editing here...

Thanks for any suggestions - I'm sure I'm in a tiny minority who cares about this so I don't fault the maintainers of the web site for using these key combos...


01-03-2005, 03:10 PM
thanks for the comments eraas :)

Try changing your posting options in the User CP (http://www.volvoxc.com/forums/usercp.php?) under Edit Options (http://www.volvoxc.com/forums/profile.php?do=editoptions) in the very bottom option of Message Editor Interface from
Enhanced Interface - Fill WYSIWYG Editing
Standard Editor - Extra formatting controls

That should disable the keyboard shortcuts, if not change it to Basic Editor - A simple text box

Let me know how that works for ya :)

01-03-2005, 05:25 PM
Thanks for the tip! Switching to basic editor disabled the control-b shortcut for inserting bold text, but control-p still activates 'Preview Post'

Well I can live with it - just thought I'd check if there was a way to override it.