Results 1 to 4 of 4
  1. #1
    Join Date
    Jun 2003
    Location
    South Lake Tahoe, CA
    Posts
    632

    Default Seat memory adjustment not working

    The driver seat memory adjustment has quit working except for the mirrors. When I push the button on the outside of the seat nothing happens but the windows adjust to the preset setting for that button. However, the manual adjustments still work.

    I there a fuse for the memory function? Any other suggestions?
    Last edited by wgriswold; 07-23-2019 at 11:14 AM.
    Wait Griswold
    2003 XC70
    South Lake Tahoe, CA

  2. #2
    Join Date
    Feb 2011
    Location
    Windy Manitoba
    Posts
    626

    Default

    Have you tried resetting the seat memory? Adjust it to where you want then press M and the memory number button at the same time.

  3. #3
    Join Date
    Aug 2017
    Location
    Pleasanton CA USA
    Posts
    361

    Default

    Can you store new sideview mirror angles for drivers 1, 2 and 3? If so, then the "M" button is proved working. If not, then most likely the "M" button is shot.
    I had to replace the power-seat control switch assy. on a 2007 S60. Disconnect the battery during the entire swap procedure. Have ignition key in "II" position while reconncting 12V power.

  4. #4
    Join Date
    Jun 2003
    Location
    South Lake Tahoe, CA
    Posts
    632

    Default

    I was able to store the mirror angles so the M button is working. I also was able to store the seat positions and now the three positions all work. Maybe somehow resetting the three positions brought it back to life? A mystery, but all is well now.

    Thanks for your help.
    Wait Griswold
    2003 XC70
    South Lake Tahoe, CA

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •