Results 1 to 6 of 6

Thread: 2004 XC90 2.9 Turbocharger issue

  1. #1
    Join Date
    May 2015
    Location
    Maryland
    Posts
    16

    Default 2004 XC90 2.9 Turbocharger issue

    Yesterday morning my XC90 threw a 0234 code and it feels like the turbo has been disabled. On inspection I can see an oily mix is being sprayed out onto the pipes that lead to the turbocharger as per the picture. Any idea on what is causing this? Thanks for any input.

    [URL="https://ibb.co/592CtKT"]https://ibb.co/592CtKT[/URL

    https://ibb.co/Wsg9NqV

  2. #2
    Join Date
    Dec 2009
    Location
    GA
    Posts
    1,181

    Default

    Quote Originally Posted by volvoxc90bob View Post
    Yesterday morning my XC90 threw a 0234 code and it feels like the turbo has been disabled. On inspection I can see an oily mix is being sprayed out onto the pipes that lead to the turbocharger as per the picture. Any idea on what is causing this? Thanks for any input.
    P0234 is a overboost related code. A common failure is the plastic pipe from the turbos to the intercooler cracks, causes funny noises under boost, air leaks, - 30636959 - it cracks where the two pipes join together -

  3. #3
    Join Date
    May 2015
    Location
    Maryland
    Posts
    16

    Default

    Thanks Hoonk, I cleared the code and she stayed off for awhile but she just came back on. I'm going to replace that plastic pipe and report back.

  4. #4
    Join Date
    Dec 2009
    Location
    GA
    Posts
    1,181

    Default

    Quote Originally Posted by volvoxc90bob View Post
    I'm going to replace that plastic pipe
    That pipe is expensive, hope that's the cause
    Last edited by hoonk; 03-29-2019 at 08:34 AM.

  5. #5
    Join Date
    May 2015
    Location
    Maryland
    Posts
    16

    Default

    I replaced the plastic pipe, the old one did have cracks and the whistle is gone but I'm still throwing the p0234 when I open her up. I hooked a vacuum pump up to the hose that goes to the turbo waste gate and I get vacuum but the vacuum doesnt hold for long, I'm not sure if this is normal and I don't have a smoker to search for a leak. All of the other hoses appear to be intact and are fairly new as well as the turbo boost sensor being fairly new. I'm frustrated and about ready to take her to a shop. I'm wondering if it's the waste gates?

  6. #6
    Join Date
    May 2015
    Location
    Maryland
    Posts
    16

    Default

    Took to local indy today, the diaphram in one of the waste gates is shot and you have to replace the whole turbo. $2500 to replace 750 for the part and 9 hours of labor. Of course you have to do both sides at this point in time so we tack on another $8-900. She only has 205k on her, looks great and all kinds of new parts so we further invested in her.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •