Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Haldex issues. 2005 xc70

  1. #11
    Join Date
    Feb 2013
    Location
    Boston, MA
    Posts
    1,021

    Default

    Quote Originally Posted by Xfingers View Post
    Thanks again, vtl. It won't surprise me if the bolts turn out to be welded/fused/bonded to the DEM. I can't quite picture "drill the slot on Haldex along the bolt." Maybe if I'm looking at the DEM it'll make more sense.
    The bolt freezes in Haldex case, not in DEM. See the first two pictures in the thread.

    Did this require repair to the DEM after the bolt was removed or were you able to just thread a new bolt and you were good to go? I guess I'll burn this bridge when I get to it.
    No, DEM is not damaged. You can simply drill bolts heads out, lift DEM up and then deal with the frozen bolts. If you have to cut the slot you'll need to repair it after, so the threads will remain sealed. I used JB Weld.
    2002 V70 (sold)
    2005 XC70 (Telos Road took it. Did a chassis swap)
    2016 XC60

  2. #12
    Join Date
    Jun 2013
    Location
    Northeast
    Posts
    429

    Default

    OK, vtl, appreciate the clarification. Now I see what I'm up against. Yeah, I see how the haldex unit would definitely need to come out. Thank you!
    2007 XC70, 206,000 miles
    2002 V70XC, 130,000 miles, parts car

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •