Results 1 to 10 of 10

Thread: Parking lights not flashing on lock

  1. #1
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    593

    Default Parking lights not flashing on lock

    2007 XC70...My parking lights used to flash when I locked the car. They suddenly stopped flashing. The car still locks and the alarm light blinks, but no more visual cue that the car is locked....

    No recent service or changes to the vehicle

    Any idea why this suddenly stopped?
    2017 Maserati Ghibli - Blu Emozione, Black Leather 7k miles
    2013 Subaru Outback - charcoal Grey, Eyesight Collision Avoidance 90k miles
    2007 XC70, Barents Blue, Charcoal Leather 190k miles
    2001 Honda Accord V6 SE - 78k miles - Steady reliable transport
    1978 Bitchin' Chevrolet Z28 Camaro - Fuel Injected 383ci SB Dyno'd at 452HP 462FT/LBs Torque
    My build thread: http://www.nastyz28.com/forum/showthread.php?t=276139

  2. #2
    Join Date
    Jul 2010
    Location
    Halifax, Nova Scotia, Canada
    Posts
    20

    Default

    This is going to sound strange, but try opening and closing the hood.

  3. #3
    Join Date
    Sep 2002
    Location
    Belgium
    Posts
    2,337

    Default

    The turn indicators flash when the alarm becomes active. If they don't flash, it often means that one of
    the doors are not (fully) closed. As mentioned above, this can be the hood, but also one of the doors,
    including the cargo door. When the turn indicators haven't flashed, the alarm is probably not active.
    You can test this by opening doors and see (or rather hear) if the sirene comes on. If all doors are firmly
    closed, there may be something wrong with one of the door-switches. Again, the hood is a known suspect.
    144 GL (1974)--->244 GL (1982)--->940 GLE 2.3i (1992)--->XC70 2.5T (2004)--->XC90 T5 (2018)

  4. #4
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    593

    Default

    Thanks. I checked and all the doors and hood are tightly closed. I did recently lubricate the hood latches but that seems unlikely to have caused it.

    Where is the button or latch that indicates the hood is closed and the doors. I looked around for a pressure switch in the doors and hood to test but could not find one.

    Thanks again!
    2017 Maserati Ghibli - Blu Emozione, Black Leather 7k miles
    2013 Subaru Outback - charcoal Grey, Eyesight Collision Avoidance 90k miles
    2007 XC70, Barents Blue, Charcoal Leather 190k miles
    2001 Honda Accord V6 SE - 78k miles - Steady reliable transport
    1978 Bitchin' Chevrolet Z28 Camaro - Fuel Injected 383ci SB Dyno'd at 452HP 462FT/LBs Torque
    My build thread: http://www.nastyz28.com/forum/showthread.php?t=276139

  5. #5
    Join Date
    Sep 2002
    Location
    Belgium
    Posts
    2,337

    Default

    There is also the possiblity that the switch, or rather the wiring to the switch, of the cargo door is broken.
    It's a known item, there are a lot of threads about it such as this one:
    http://www.volvoxc.com/forums/showth...go+door+wiring
    144 GL (1974)--->244 GL (1982)--->940 GLE 2.3i (1992)--->XC70 2.5T (2004)--->XC90 T5 (2018)

  6. #6
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    593

    Default

    I checked the rear harness and it is fine. There must be a bad switch in one of the doors or hood. Any idea how to find them? They are not obvious when looking.
    2017 Maserati Ghibli - Blu Emozione, Black Leather 7k miles
    2013 Subaru Outback - charcoal Grey, Eyesight Collision Avoidance 90k miles
    2007 XC70, Barents Blue, Charcoal Leather 190k miles
    2001 Honda Accord V6 SE - 78k miles - Steady reliable transport
    1978 Bitchin' Chevrolet Z28 Camaro - Fuel Injected 383ci SB Dyno'd at 452HP 462FT/LBs Torque
    My build thread: http://www.nastyz28.com/forum/showthread.php?t=276139

  7. #7
    Join Date
    Apr 2010
    Location
    New England
    Posts
    27

    Default

    Try slamming the hood (drop it from a good distance). Seriously. This resolved the issue on the wife's 05 XC. Something was sticking and the height of the drop shook it loose.
    ---
    '04 AWD
    '05 XC (totaled in a rear end collision; RIP)
    '06 XC

  8. #8
    Join Date
    Aug 2007
    Location
    NJ
    Posts
    593

    Default

    Would a failing alarm battery cause this to happen? Canít find any of the door or hood latch switches....
    2017 Maserati Ghibli - Blu Emozione, Black Leather 7k miles
    2013 Subaru Outback - charcoal Grey, Eyesight Collision Avoidance 90k miles
    2007 XC70, Barents Blue, Charcoal Leather 190k miles
    2001 Honda Accord V6 SE - 78k miles - Steady reliable transport
    1978 Bitchin' Chevrolet Z28 Camaro - Fuel Injected 383ci SB Dyno'd at 452HP 462FT/LBs Torque
    My build thread: http://www.nastyz28.com/forum/showthread.php?t=276139

  9. #9
    Join Date
    Sep 2002
    Location
    Belgium
    Posts
    2,337

    Default

    Quote Originally Posted by 8pack View Post
    Would a failing alarm battery cause this to happen? Can’t find any of the door or hood latch switches....
    Perhaps not impossible, but it's not what happend when the siren module failed in our XC70
    and I can't remember reading anywhere that it caused the lights not to flash.
    144 GL (1974)--->244 GL (1982)--->940 GLE 2.3i (1992)--->XC70 2.5T (2004)--->XC90 T5 (2018)

  10. #10
    Join Date
    Mar 2008
    Location
    Western Head, Nova Scotia
    Posts
    3,034

    Default

    Quote Originally Posted by Willy View Post
    Perhaps not impossible, but it's not what happend when the siren module failed in our XC70
    and I can't remember reading anywhere that it caused the lights not to flash.
    Same with me and my '05 XC.

    Cheers,

    Bill
    Western Head, NS CDN

    '05 V70R (Magic Blue)-118K mi to-date
    '05 XC70 (Lava Sand)-270K kms to-date
    '02 V70XC-gone @393K kms
    '98 V70-gone @390k kms
    '91 744GL-killed by son @ 220K kms
    '96 854R (Red)-real CDN-spec 5-speed R - gone @270k kms
    '90 744T w/Turbo Plus-killed by son @260K mi
    '78 245-killed by wife @166K mi
    '76 265-gas hog gone
    And other misc. Euro stuff

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •