Results 1 to 9 of 9

Thread: 2001 Volvo XC70 AWD Transmission problem!!! Please help!!!

  1. #1
    Join Date
    Nov 2012
    Location
    chicago
    Posts
    4

    Exclamation 2001 Volvo XC70 AWD Transmission problem!!! Please help!!!

    Hi,my car started acting realy weird when shifting from 2 to 3 gear only!!! Other than that it changes all the gears like it should(upshift and downshift). Just before engageing into 3rd ,the car dives for a sek. and then goes into gear. It is worst when the car is cold in the morning. Could this be a motor mount? Please help!

  2. #2
    Join Date
    May 2010
    Location
    NNY/NJ
    Posts
    343

    Default

    Sir,

    I would recommend you search this forum.

    2001 transmissions have a known problem with line pressure dropping, and require replacing the valve bodies and/or rebuilding.
    The 2-3 shift is the most common sympton.

    Unfortunately this is a grave problem, and not a simple fix.
    I'm sorry I couldn't give you better news.

    Andres

    Andres
    2013 XC70 T6, Premier Plus, BLIS Black/Black 7K miles, stock
    2004 XC70 Premium, Convenience, Climate Blue/Tan 115K miles, 2007+ ABL lights, IPD sways F & R, TME exhaust, SS brake lines, R Brembo calipers & rotors, Akebono ceramic pads F & R (replaced PCV, power steering rack, struts and springs, end links, ball joints, A-arms, all fluids)

  3. #3
    Join Date
    Nov 2012
    Location
    chicago
    Posts
    4

    Default

    Thank you for your respond!

  4. #4
    Join Date
    Apr 2012
    Location
    Nova Scotia
    Posts
    100

    Default

    As you only get that for the 2-3 shift, there's a good chance it's the B4 servo cover. Check your transmission serial number, see if it falls within the range described here: http://www.v70xc.com/resources/how-t...ervo-cover.pdf

    If so it's only a $20 part to fix. The VB is probably worn anyway from that year car, but your specific problem might be improved upon!

  5. #5
    Join Date
    Jan 2009
    Location
    Nebraska
    Posts
    1,285

    Default

    Quote Originally Posted by yulio78 View Post
    Just before engageing into 3rd ,the car dives for a sek. and then goes into gear. It is worst when the car is cold in the morning.
    A delayed 2-3 upshift is normal in cold weather. If it continues to do this once the car is warmed up however, I would first check the level and condition of the transmission fluid, if it's never been changed it would be as well to do it. If this doesn't solve your problems you will need to check for problems with the B4-servo cover or look into servicing the valve body.

  6. #6
    Join Date
    Nov 2012
    Location
    chicago
    Posts
    4

    Default

    thank you guys,how hard is to get to VB and how can i check the serial #.
    if i have to buy a new VB,solenoid and Servo cover what would be the best place to get the parts,also forgot to mention that there is any trouble codes.

  7. #7
    Join Date
    Apr 2003
    Location
    Devon PA
    Posts
    9,195

    Default

    You can't very easily and this is not an easy deal to begin with.
    You need to post INFO
    Like your mileage to start with! If it's very high, a new or rebuilt V/B will likely so you no good as the rest of the tranny is plain, worn out.
    You just don't start throwing $1000 into something blindly without some research, a couple of people telling you it MAY be the valvebody is not research.

    Most likely if it has over 150-160K miles you will need a new (factory rebuilt) transmission at a cost of $4000-5K inclusive.
    The case may be worn, there are other parts that will probably be worn out, clutch packs, etc. It's not likely a valvebody will make it like new again as it's not new
    Email: jrl1194(at)aol.com
    If the subject is car purchase related please use jrl1194(at)gmail.com
    2006 XC70 White/Black 58K miles, new daily driver
    2000 V70R wife's. Won't sell, now 120K miles and still perfect
    1994 Lincoln Continental. In concours condition with low miles.

  8. #8
    Join Date
    Nov 2012
    Location
    chicago
    Posts
    4

    Default

    Coflynn,THANK YOU ,THANK YOU ,THANK YOU!!!!!!!!!! problem solved!!!!!!!!! i ve got the b4 servo cover replaced and my car shifts like new now.

  9. #9
    Join Date
    Oct 2011
    Location
    Northshore - Great Lakes
    Posts
    479

    Default

    Quote Originally Posted by yulio78 View Post
    Coflynn,THANK YOU ,THANK YOU ,THANK YOU!!!!!!!!!! problem solved!!!!!!!!! i ve got the b4 servo cover replaced and my car shifts like new now.
    A positive outcome, thanks to Coflynn's keen observation.
    Yulio, would you tell us the tranny's serial number. Looking down the opened hood, it is on a small 2"x 1" metal plate on tranny housing, most likely starting with 01...
    Last edited by Xheart; 02-13-2013 at 09:43 AM.
    2001 V70XC - Nautic Blue/ 2-tone Sand/ Premium/ All Original/ Pirelli P4 12/32" - 740/ Duracell 48/ MOBIL-3309/ Pennzoil 5W-30/ Zimmerman Z-coated/ Akebono/ 146K-mi/ Great Lakes

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •