Results 1 to 5 of 5

Thread: Cruise control problem

  1. #1
    Join Date
    Jan 2010
    Location
    kentucky
    Posts
    2

    Default Cruise control problem

    Hello. New to the site after recently purchasing a 2004 XC90 T6. Must say this is a very informative place. I'm having a problem with the cruise control not staying engaged. It will come on initially but "let go" after about 30 seconds. I can't reengage until the car has been turned off and restarted. Any ideas or suggestions? Thanks in advance

  2. #2
    Art's Avatar
    Art is offline Super Moderator & VolvoXC.com Supporter
    Join Date
    Oct 2001
    Location
    Red Deer, AB., Canada
    Posts
    4,118

    Default

    Hmm…sounds familiar. A number of members in the XC70 forum have experienced similar cruise control issues that were related to a faulty brake pedal position sensor. You should be able to come across a few hits by doing a search in that forum.

  3. #3
    Join Date
    Jan 2010
    Location
    kentucky
    Posts
    2

    Default

    Thanks for the info. Is that something that can be done myself? If so, where do I start?

  4. #4
    Art's Avatar
    Art is offline Super Moderator & VolvoXC.com Supporter
    Join Date
    Oct 2001
    Location
    Red Deer, AB., Canada
    Posts
    4,118

    Default

    A good start would be to have your dealer check for any stored codes that might indicate a malfunctioning sensor or brake light switch. One sure sign would be brake lights that are constantly lit.

  5. #5
    Join Date
    Mar 2013
    Posts
    4

    Default

    We have the same symptoms you have... did you ever get this fixed? If so, what was the root cause? -- does the cruise control now stay engaged for more than 30 seconds? :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •