Results 1 to 9 of 9

Thread: Check Engine Light ON - Code PO442

  1. #1
    Join Date
    Jan 2009
    Location
    Rhode Island
    Posts
    19

    Default Check Engine Light ON - Code PO442

    My Check Engine light came on last week shortly after a fill up at the gas station. I checked the code using a generic scanner and it pulled code PO442. I have also randomly been getting a message on the instrument panel saying that the 'fuel filler door is open-loose".

    I ended up replacing the gas cap clearing the CE code and the message came back shortly after, but the CEL has not come back yet. I recently had a software upgrade for the Leak Detection software download for the ECM air pump and I'm not sure if the PO442 code is related to a bad air pump or maybe the charcoal canister is bad. Sometimes when I fill up the car the pump will auto shut off and then spill a ton of gas as though I overfilled the car (not sure why because I stop pumping when the pump shuts off).

    Here is a photo of what I see underneath the car looking up at the fuel door:



    Are the hoses with the arrows pointing to them supposed to not have anything connected to them?

  2. #2
    Join Date
    Jan 2009
    Location
    Ontario,Canada
    Posts
    151

    Default

    I have a 2003. If we are looking at the same thing I do have hoses coming from there.

    I'm looking up behind the rear wheel to the side of the gas tank. I see a bunch of hoses there. I see that tubular shaped thing with a hose coming out of where your arrow points.

    Jim

  3. #3
    Join Date
    Jan 2009
    Location
    Rhode Island
    Posts
    19

    Default

    Jim

    Could you supply a photo by any chance?

  4. #4
    Join Date
    Jan 2009
    Location
    Ontario,Canada
    Posts
    151

    Default

    When my wife gets home with the car I'll take a picture.

    Jim

  5. #5
    Join Date
    Jan 2008
    Location
    Arlington/Newport News, VA
    Posts
    929

    Default

    Those might just be breather tubes for the gas tanks, but don't quote me on that one.

    '05 XC70
    -Pioneer Avic F700bt headunit
    -12 inch Alpine Type R Sub
    -Flat Black Pegs
    -Custom Tinted Windows
    -Custom Mesh Grille
    -OBX Catback Exhaust
    -IPD Silicone Hoses

  6. #6
    Join Date
    Jan 2009
    Location
    Ontario,Canada
    Posts
    151

    Default

    [IMG][/IMG]

  7. #7
    Join Date
    Jan 2009
    Location
    Ontario,Canada
    Posts
    151

    Default

    [IMG][/IMG]

  8. #8
    Join Date
    Jan 2009
    Location
    Rhode Island
    Posts
    19

    Default

    That's what I thought otherwise the CEL would be on all the time right?

  9. #9
    Join Date
    Jan 2009
    Location
    Ontario,Canada
    Posts
    151

    Default

    So it is the same. Your picture is just further up..

    Quote Originally Posted by jdp6000 View Post
    [IMG][/IMG]

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •